No visits since iOS13?

Are you experiencing issues after the iOS update? We suspect there is a bug in the new iOS version. However we have seen that these steps below have solved the issue.

Please follow these steps:

1.Go to Settings > Privacy > Location Services > Scroll down to find 'System Services' > scroll down to find 'Significant locations' > Disable AND enable again. Make sure to keep this enabled at all times.

2. Restart your phone with the power button.  See if Life Cycle starts working again, you might need to let a few hours pass (change location). 

Note that significant locations now needs to be enabled at all times.

Contact support if you would have further issues. 

 

Have more questions? Submit a request

10 Comments

  • 3
    Avatar
    Ian Hall

    It'd be good if you could change the error message that the app shows in this situation.

  • 1
    Avatar
    Lindakjell

    Have followed these steps several times now and still get the same message and no visits getting logged.

  • 1
    Avatar
    EvelineWind

    Have followed the instructions several times
    now and still get the same message and no visits getting logged
    It’s annoying!

  • 0
    Avatar
    Andy Johnson

    Don't ever try to uninstall and reinstall the app.

    I lost all my 2 years of Data

  • 0
    Avatar
    M

    I have the same problem with my iPhone after upgrading to iOS13 - since the update I get no location updates at all, and despite trying to follow the steps above it does not resolve the problem.

    After having been a subscriber for two years, I’m amazed at the lack of response to a problem that, judging by recent App Store reviews, seems to be an issue that is faced by many. Needless to say that until the issue is resolved, I have cancelled my subscription renewal.

    Edited by M
  • 0
    Avatar
    EvelineWind

    I agree with the above comment!! I emailed them today, I am going to wait a week if they come with a resolution. If not I also cancel my automatic subscription renewal

  • 1
    Avatar
    Linda Gingrich

    These instructions did not fix the issue on my iPhone 6S. I believe the bug is in your code, not in the IOS code. They likely changed something in the code that is not compatible with the Life Cycle location services.

  • 1
    Avatar
    EvelineWind

    I emailed the app developers and told them that I tried a several times according to the instructions. I got as an answer: exactly the same instructions. So? I replied:”Did you actually read my question before answering?
    In my question I said that I followed the instructions already that are given.
    So?
    No your answer is not helpful.
    I already did that more than 20 times now.
    Please give an answer that solves the problem!”

  • 0
    Avatar
    LindaR

    Me too ... same issue. I'm having to log all my activities manually. I've only been using it for a week!

  • 0
    Avatar
    Ian Hall

    for everyone else having problems with this, it did work for me eventually.

     

    Settings | Privacy, then click on Location Services (even though it already says "on")

    Now scroll all the way to the bottom and click on "System Services"

    Scroll all the way down - at the bottom you should see "PRODUCT IMPROVEMENT". Just above that, pick "Significant Locations".

     

    At this point, the phone should ask for your Touch ID, before it allows you in to the "Significant Locations" section.

     

    Once you're in there, turn OFF Significant Location, then exit.

    Just to be safe, I used the < Back link to go all the way out, then re-started my phone.

     

    Once it was re-started, I went all the way back down to Sig Loc and re-enabled it.

    Then I restarted again and LifeCycle was working.

     

    Painful!!! But it's been working fine ever since.

     

    Good luck!!!

Please sign in to leave a comment.